Velocity Login Problems

By BOF | Jan 17, 2019, 10:45 AM
Is anyone else havin problems with login to the Velocity web site? Login accepts details and then returns to the home page. Trying to login again does nothing. Clicking around I can find a page saying the site is undergoing "scheduled maintenance" but its been like that for a couple of days and there are no date/time details, so I don't even know if that message is current.
No member give thanks

By djtech | Jan 17, 2019, 11:47 AM
No problems for me.
No member give thanks

By Rod H | Jan 17, 2019, 12:36 PM
Working quite OK for me as well.
No member give thanks

By StuParr | Jan 17, 2019, 12:41 PM
Maybe you need to refresh your browser, as I just had no problems. I hope it resolves soon.
No member give thanks

By BOF | Jan 17, 2019, 12:56 PM
Thanks for the feedback. Did see similar problem reported on their facebook page.
Managed to resolve by resetting Firefox!
No member give thanks

By MRYJDrake | Jan 18, 2019, 09:12 AM
Cache and Cookies, failling that, jump into incognito mode/private browsing
No member give thanks

By Jazzop | Jan 18, 2019, 01:15 PM
I used to have issues, but the re-fresh (finally) is working for me. Try the velocity app too if you haven't already.

No member give thanks

×
×

Forgot Password

If you’ve forgotten your password, simply enter your email address below, then click 'Submit'. We’ll send you an email to re-activate your account and enter a new password.

×

Resend activation email

If you have not received the activation email, simply enter your email address below, then click 'Submit'. We’ll send you an email containing the activation link.

×